이클립스에서 maven 플러그인을 설치하고 다음과 같은 에러가 나올 때…

Maven plugin을 설치하고 다음과 같은 에러가 발생하였다.

 

Eclipse is running in a JRE, but a JDK is required
Some Maven plugins may not work when importing projects or updating source folders.

eclipse.ini를 열어서 다음을 추가해준다.

-vm
C:\Program Files\Java\jdk1.6.0_10\bin\javaw.exe